gajim.org
Sign In
Sign Up
Sign In
Sign Up
Manage this list
×
Keyboard Shortcuts
Thread View
j
: Next unread message
k
: Previous unread message
j a
: Jump to all threads
j l
: Jump to MailingList overview
2026
October
September
August
July
June
May
April
March
February
January
2025
December
November
October
September
August
July
June
May
April
March
February
January
2024
December
November
October
September
August
July
June
May
April
March
February
January
2023
December
November
October
September
August
July
June
May
April
March
February
January
2022
December
November
October
September
August
July
June
May
April
March
February
January
2021
December
November
October
September
August
July
June
May
April
March
February
January
2020
December
November
October
September
August
July
June
May
April
March
February
January
2019
December
November
October
September
August
July
June
May
April
March
February
January
2018
December
November
October
September
August
July
June
May
April
March
February
January
2017
December
November
October
September
August
July
June
May
April
March
February
January
2016
December
November
October
September
August
July
June
May
April
March
February
January
2015
December
November
October
September
August
July
June
May
April
March
February
January
2014
December
November
October
September
August
July
June
May
April
March
February
January
2013
December
November
October
September
August
July
June
May
April
March
February
January
2012
December
November
October
September
August
July
June
May
April
March
February
January
2011
December
November
October
September
August
July
June
May
April
March
February
January
2010
December
November
October
September
August
July
June
May
April
March
February
January
2009
December
November
October
September
August
July
June
May
April
March
February
January
2008
December
November
October
September
August
July
June
May
April
March
February
January
2007
December
November
October
September
August
July
June
May
April
March
February
January
2006
December
November
October
September
August
July
June
May
April
List overview
Download
Commits
January 2014
----- 2026 -----
October 2026
September 2026
August 2026
July 2026
June 2026
May 2026
April 2026
March 2026
February 2026
January 2026
----- 2025 -----
December 2025
November 2025
October 2025
September 2025
August 2025
July 2025
June 2025
May 2025
April 2025
March 2025
February 2025
January 2025
----- 2024 -----
December 2024
November 2024
October 2024
September 2024
August 2024
July 2024
June 2024
May 2024
April 2024
March 2024
February 2024
January 2024
----- 2023 -----
December 2023
November 2023
October 2023
September 2023
August 2023
July 2023
June 2023
May 2023
April 2023
March 2023
February 2023
January 2023
----- 2022 -----
December 2022
November 2022
October 2022
September 2022
August 2022
July 2022
June 2022
May 2022
April 2022
March 2022
February 2022
January 2022
----- 2021 -----
December 2021
November 2021
October 2021
September 2021
August 2021
July 2021
June 2021
May 2021
April 2021
March 2021
February 2021
January 2021
----- 2020 -----
December 2020
November 2020
October 2020
September 2020
August 2020
July 2020
June 2020
May 2020
April 2020
March 2020
February 2020
January 2020
----- 2019 -----
December 2019
November 2019
October 2019
September 2019
August 2019
July 2019
June 2019
May 2019
April 2019
March 2019
February 2019
January 2019
----- 2018 -----
December 2018
November 2018
October 2018
September 2018
August 2018
July 2018
June 2018
May 2018
April 2018
March 2018
February 2018
January 2018
----- 2017 -----
December 2017
November 2017
October 2017
September 2017
August 2017
July 2017
June 2017
May 2017
April 2017
March 2017
February 2017
January 2017
----- 2016 -----
December 2016
November 2016
October 2016
September 2016
August 2016
July 2016
June 2016
May 2016
April 2016
March 2016
February 2016
January 2016
----- 2015 -----
December 2015
November 2015
October 2015
September 2015
August 2015
July 2015
June 2015
May 2015
April 2015
March 2015
February 2015
January 2015
----- 2014 -----
December 2014
November 2014
October 2014
September 2014
August 2014
July 2014
June 2014
May 2014
April 2014
March 2014
February 2014
January 2014
----- 2013 -----
December 2013
November 2013
October 2013
September 2013
August 2013
July 2013
June 2013
May 2013
April 2013
March 2013
February 2013
January 2013
----- 2012 -----
December 2012
November 2012
October 2012
September 2012
August 2012
July 2012
June 2012
May 2012
April 2012
March 2012
February 2012
January 2012
----- 2011 -----
December 2011
November 2011
October 2011
September 2011
August 2011
July 2011
June 2011
May 2011
April 2011
March 2011
February 2011
January 2011
----- 2010 -----
December 2010
November 2010
October 2010
September 2010
August 2010
July 2010
June 2010
May 2010
April 2010
March 2010
February 2010
January 2010
----- 2009 -----
December 2009
November 2009
October 2009
September 2009
August 2009
July 2009
June 2009
May 2009
April 2009
March 2009
February 2009
January 2009
----- 2008 -----
December 2008
November 2008
October 2008
September 2008
August 2008
July 2008
June 2008
May 2008
April 2008
March 2008
February 2008
January 2008
----- 2007 -----
December 2007
November 2007
October 2007
September 2007
August 2007
July 2007
June 2007
May 2007
April 2007
March 2007
February 2007
January 2007
----- 2006 -----
December 2006
November 2006
October 2006
September 2006
August 2006
July 2006
June 2006
May 2006
April 2006
commits@gajim.org
3 participants
34 discussions
Start a n
N
ew thread
gajim: "4096-bit MODP Group" from RFC3526, Section 5.
by Gajim
31 Jan '14
31 Jan '14
changeset 6892eee71437 in /home/hg/repos/gajim author: Fedor Brunner <fedor.brunner(a)azet.sk> branches: gajim_0.16
details:http://hg.gajim.org/gajim?cmd=changeset;node=6892eee71437
description: "4096-bit MODP Group" from RFC3526, Section 5. The prime is: 2^4096 - 2^4032 - 1 + 2^64 * { [2^3966 pi] + 240904 } RFC3526 specifies a generator of 2. The generation of the group is described in RFC 2412. Fixes: #7644 diffstat: data/other/dh4096.pem | 30 +++++++++++++++++++----------- src/common/jingle_xtls.py | 4 ---- 2 files changed, 19 insertions(+), 15 deletions(-) diffs (50 lines): diff -r 028705b6a08f -r 6892eee71437 data/other/dh4096.pem --- a/data/other/dh4096.pem Thu Jan 30 17:17:25 2014 +0100 +++ b/data/other/dh4096.pem Fri Jan 31 16:29:38 2014 +0100 @@ -1,13 +1,21 @@ -----BEGIN DH PARAMETERS----- -MIICCAKCAgEA9RBdjft9pcfy2WZWWgz7uKzHg0O8ltdU045O5aZIkbmfe6ec6spu -GlJwCpA8FpRK99R2JYZkPDuJkJOR3Yonm3leJB8ZO1sgak36tf1KXosn86STtwh8 -ppA27Idx4dZwFn8wPCnfcVqCq/4DXR7mB3miHOMZx8kmjhRO86doTZHWsTYej1ei -pbk9lekYJzI7ohEITnLoiUKfquzfg71JGcGKF6dvXlcc4iXuPluqz1fsua4eY/tm -kPlvqoYXsmtQIszk2YIsgk8kDBv9BBbcFITXDFEMxPc5Qof4MTTHWOHvyyXqiNJt -d1cWkrpGKx+H2MDoLW8Ssf3v/oCj3tP+LbOa+rqme39ARK8SZpimjkBw0qMQcIux -LTXFPrLTszzza3Nfthtc1H1MuoVsdJSDjTe94FajPewsI3Cc2fVgSh6puS6S3gsf -dblNMNYRjQSMRr3LGahSnWOG6ux+1Nau3hCwCOIZpZs3DZurRZ+EFYWxG+83DMlu -Vxg7cXrzofyBShb/lVCERVyKCuGIAJSkKfC/D5tcCHHEB34ep8ZMc+2UEslK8dSW -4cQcqG3/KOwpsV0zXfaX0xhS8/95gnAgCZRiDiUWVskJ6JxWvqg40N2dBK7tT/Gq -sayPDdAY/B/lBfcJzuD6uxCf1wBCMtg01bVe7tipxSlhGgBpKBoJa4sCAQI= +MIICCAKCAgEA///////////JD9qiIWjCNMTGYouA3BzRKQJOCIpnzHQCC76mOxOb +IlFKCHmONATd75UZs806QxswKwpt8l8UN0/hNW1tUcJF5IW1dmJefsb0TELppjft +awv/XLb0Brft7jhr+1qJn6WunyQRfEsf5kkoZlHs5Fs9wgB8uKFjvwWY2kg2HFXT +mmkWP6j9JM9fg2VdI9yjrZYcYvNWIIVSu57VKQdwlpZtZww1Tkq8mATxdGwIyhgh +fDKQXkYuNs474553LBgOhgObJ4Oi7Aeij7XFXfBvTFLJ3ivL9pVYFxg5lUl86pVq +5RXSJhiY+gUQFXKOWoqqxC2tMxcNBFB6M6hVIavfHLpk7PuFBFjb7wqK6nFXXQYM +fbOXD4Wm4eTHq/WujNsJM9cejJTgSiVhnc7j0iYa0u5r8S/6BtmKCGTYdgJzPshq +ZFIfKxgXeyAMu+EXV3phXWx3CYjAutlG4gjiT6B05asxQ9tb/OD9EI5LgtEgqSEI +ARpyPBKnh+bXiHGaEL26WyaZwycYavTiPBqUaDS2FQvaJYPpyirUTOjbu8LbBN6O ++S6O/BQfvsqmKHxZR05rwF2ZspZPoJDDoiM7oYZRW+ftH2EpcM7i16+4G912IXBI +HNAGkSfVsFqpk7TqmI2P3cGG/7fckKbAj030Nck0BjGZ//////////8CAQI= -----END DH PARAMETERS----- + +"4096-bit MODP Group" from RFC3526, Section 5. + +The prime is: 2^4096 - 2^4032 - 1 + 2^64 * { [2^3966 pi] + 240904 } + +RFC3526 specifies a generator of 2. + +The generation of the group is described in RFC 2412. diff -r 028705b6a08f -r 6892eee71437 src/common/jingle_xtls.py --- a/src/common/jingle_xtls.py Thu Jan 30 17:17:25 2014 +0100 +++ b/src/common/jingle_xtls.py Fri Jan 31 16:29:38 2014 +0100 @@ -121,10 +121,6 @@ with open(dh_params_name, "r") as dh_params_file: ctx.load_tmp_dh(str(dh_params_name)) except IOError as err: - log.warn('Unable to load DH parameter file: %s. You should generate it ' - 'by using this command : "openssl dhparam 4096 -out ' - '~/.config/gajim/dh_params.pem". This command take about 15 ' - 'minutes to complete.' % dh_params_name) default_dh_params_name = os.path.join(common.gajim.DATA_DIR, 'other', DEFAULT_DH_PARAMS) try:
1
0
0
0
gajim: Update entropy gathering for interface changes of pyOpenSSL.
by Gajim
30 Jan '14
30 Jan '14
changeset 028705b6a08f in /home/hg/repos/gajim author: Fedor Brunner <fedor.brunner(a)azet.sk> branches: gajim_0.16
details:http://hg.gajim.org/gajim?cmd=changeset;node=028705b6a08f
description: Update entropy gathering for interface changes of pyOpenSSL. Fixes: #7642 diffstat: src/common/crypto.py | 20 ++++++++++---------- src/gajim.py | 2 +- 2 files changed, 11 insertions(+), 11 deletions(-) diffs (42 lines): diff -r e7666c925c22 -r 028705b6a08f src/common/crypto.py --- a/src/common/crypto.py Thu Jan 30 14:19:37 2014 +0100 +++ b/src/common/crypto.py Thu Jan 30 17:17:25 2014 +0100 @@ -98,16 +98,16 @@ dirs = ['/proc', '/proc/net', '/proc/self'] for d in dirs: if os.access(d, os.R_OK): - for filename in os.listdir(d): - OpenSSL.rand.add(filename, 0) - try: - with open(d + os.sep + filename, "r") as fp: - # Limit the ammount of read bytes, in case a memory - # file was opened - OpenSSL.rand.add(str(fp.read(5000)), 0.01) - except: - # Ignore all read and access errors - pass + for filename in os.listdir(d): + OpenSSL.rand.add(filename, 0) + try: + with open(d + os.sep + filename, "r") as fp: + # Limit the ammount of read bytes, in case a memory + # file was opened + OpenSSL.rand.add(str(fp.read(5000)), 1) + except IOError: + # Ignore all read and access errors + pass PYOPENSSL_PRNG_PRESENT = False try: diff -r e7666c925c22 -r 028705b6a08f src/gajim.py --- a/src/gajim.py Thu Jan 30 14:19:37 2014 +0100 +++ b/src/gajim.py Thu Jan 30 17:17:25 2014 +0100 @@ -463,7 +463,7 @@ def on_exit(): # Save the entropy from OpenSSL PRNG if PYOPENSSL_PRNG_PRESENT: - OpenSSL.rand.write_file(RNG_SEED) + OpenSSL.rand.write_file(str(RNG_SEED)) # delete pid file on normal exit if os.path.exists(pid_filename): os.remove(pid_filename)
1
0
0
0
gajim: Fix changes in interface of pyOpenSSL.
by Gajim
30 Jan '14
30 Jan '14
changeset e7666c925c22 in /home/hg/repos/gajim author: Fedor Brunner <fedor.brunner(a)azet.sk> branches: gajim_0.16
details:http://hg.gajim.org/gajim?cmd=changeset;node=e7666c925c22
description: Fix changes in interface of pyOpenSSL. Fixes: #7642 diffstat: src/common/crypto.py | 2 +- src/common/jingle_xtls.py | 4 ++-- src/gajim.py | 2 +- 3 files changed, 4 insertions(+), 4 deletions(-) diffs (45 lines): diff -r 65b506a4086d -r e7666c925c22 src/common/crypto.py --- a/src/common/crypto.py Wed Jan 29 22:10:48 2014 +0100 +++ b/src/common/crypto.py Thu Jan 30 14:19:37 2014 +0100 @@ -87,7 +87,7 @@ os.environ, os.getcwd(), os.getpid()] for s in sources: - OpenSSL.rand.add(str(s), 0.01) + OpenSSL.rand.add(str(s), 1) # On Windows add the current contents of the screen to the PRNG state. if os.name == 'nt': diff -r 65b506a4086d -r e7666c925c22 src/common/jingle_xtls.py --- a/src/common/jingle_xtls.py Wed Jan 29 22:10:48 2014 +0100 +++ b/src/common/jingle_xtls.py Thu Jan 30 14:19:37 2014 +0100 @@ -119,7 +119,7 @@ dh_params_name = os.path.join(gajim.MY_CERT_DIR, DH_PARAMS) try: with open(dh_params_name, "r") as dh_params_file: - ctx.load_tmp_dh(dh_params_name) + ctx.load_tmp_dh(str(dh_params_name)) except IOError as err: log.warn('Unable to load DH parameter file: %s. You should generate it ' 'by using this command : "openssl dhparam 4096 -out ' @@ -129,7 +129,7 @@ 'other', DEFAULT_DH_PARAMS) try: with open(default_dh_params_name, "r") as default_dh_params_file: - ctx.load_tmp_dh(default_dh_params_name) + ctx.load_tmp_dh(str(default_dh_params_name)) except IOError as err: log.error('Unable to load default DH parameter file: %s , %s' % (default_dh_params_name, err)) diff -r 65b506a4086d -r e7666c925c22 src/gajim.py --- a/src/gajim.py Wed Jan 29 22:10:48 2014 +0100 +++ b/src/gajim.py Thu Jan 30 14:19:37 2014 +0100 @@ -310,7 +310,7 @@ from common import crypto PYOPENSSL_PRNG_PRESENT = True # Seed from file - OpenSSL.rand.load_file(RNG_SEED) + OpenSSL.rand.load_file(str(RNG_SEED)) crypto.add_entropy_sources_OpenSSL() except ImportError: log.info("PyOpenSSL PRNG not available")
1
0
0
0
gajim: fix receiving highlighted corrected message. Fixes #7431
by Gajim
29 Jan '14
29 Jan '14
changeset 65b506a4086d in /home/hg/repos/gajim author: Yann Leboulanger <asterix(a)lagaule.org> branches: gajim_0.16
details:http://hg.gajim.org/gajim?cmd=changeset;node=65b506a4086d
description: fix receiving highlighted corrected message. Fixes #7431 diffstat: src/conversation_textview.py | 6 ++++-- src/groupchat_control.py | 40 ++++++++++++++++++++++++++++++++++++++-- 2 files changed, 42 insertions(+), 4 deletions(-) diffs (73 lines): diff -r 1e160dfa3c32 -r 65b506a4086d src/conversation_textview.py --- a/src/conversation_textview.py Wed Jan 29 14:12:10 2014 +0100 +++ b/src/conversation_textview.py Wed Jan 29 22:10:48 2014 +0100 @@ -474,7 +474,8 @@ self.last_sent_message_marks[1] = buffer_.create_mark(None, i2, left_gravity=True) - def correct_last_received_message(self, message, xhtml, name, old_txt): + def correct_last_received_message(self, message, xhtml, name, old_txt, + other_tags_for_name=[], other_tags_for_text=[]): if name not in self.last_received_message_marks: return m1 = self.last_received_message_marks[name][0] @@ -485,7 +486,8 @@ txt = buffer_.get_text(i1, i2) buffer_.delete(i1, i2) i2 = self.print_conversation_line(message, '', 'incoming', name, None, - xhtml=xhtml, iter_=i1) + other_tags_for_name=other_tags_for_name, + other_tags_for_text=other_tags_for_text, xhtml=xhtml, iter_=i1) tt_txt = _('<b>Message was corrected. Last message was:</b>\n %s') % \ gobject.markup_escape_text(old_txt) self.show_corrected_message_warning(i2, tt_txt) diff -r 1e160dfa3c32 -r 65b506a4086d src/groupchat_control.py --- a/src/groupchat_control.py Wed Jan 29 14:12:10 2014 +0100 +++ b/src/groupchat_control.py Wed Jan 29 22:10:48 2014 +0100 @@ -1025,8 +1025,44 @@ obj.xhtml_msgtxt, obj.nick, old_txt) else: old_txt = self.last_received_txt[obj.nick] - self.conv_textview.correct_last_received_message(obj.msgtxt, - obj.xhtml_msgtxt, obj.nick, old_txt) + (highlight, sound) = self.highlighting_for_message(obj.msgtxt, obj.timestamp) + other_tags_for_name = [] + other_tags_for_text = [] + if obj.nick in self.gc_custom_colors: + other_tags_for_name.append('gc_nickname_color_' + \ + str(self.gc_custom_colors[obj.nick])) + else: + self.gc_count_nicknames_colors += 1 + if self.gc_count_nicknames_colors == \ + self.number_of_colors: + self.gc_count_nicknames_colors = 0 + self.gc_custom_colors[obj.nick] = \ + self.gc_count_nicknames_colors + other_tags_for_name.append('gc_nickname_color_' + \ + str(self.gc_count_nicknames_colors)) + if highlight: + # muc-specific chatstate + if self.parent_win: + self.parent_win.redraw_tab(self, 'attention') + else: + self.attention_flag = True + other_tags_for_name.append('bold') + other_tags_for_text.append('marked') + + if obj.nick in self.attention_list: + self.attention_list.remove(obj.nick) + elif len(self.attention_list) > 6: + self.attention_list.pop(0) # remove older + self.attention_list.append(obj.nick) + + if obj.msgtxt.startswith('/me ') or \ + obj.msgtxt.startswith('/me\n'): + other_tags_for_text.append('gc_nickname_color_' + \ + str(self.gc_custom_colors[obj.nick])) + self.conv_textview.correct_last_received_message( + obj.msgtxt, obj.xhtml_msgtxt, obj.nick, old_txt, + other_tags_for_name=other_tags_for_name, + other_tags_for_text=other_tags_for_text) self.last_received_txt[obj.nick] = obj.msgtxt self.last_received_id[obj.nick] = obj.stanza.getID() return
1
0
0
0
python-nbxmpp: Ubuntu 12.04.4 package python-openssl (0.12-1ubun...
by Fedor Brunner
29 Jan '14
29 Jan '14
changeset cadd7701fcfe in /home/hg/repos/python-nbxmpp
details:http://hg.gajim.org/python-nbxmpp?cmd=changeset;node=cadd7701fcfe
description: Ubuntu 12.04.4 package python-openssl (0.12-1ubuntu2.1) is based on an older version of pyOpenSSL. In this version of pyOpenSSL OpenSSL.SSL.OPENSSL_VERSION_NUMBER is not defined. Fixes: #18 diffstat: nbxmpp/tls_nb.py | 26 +++++++++++++++----------- 1 files changed, 15 insertions(+), 11 deletions(-) diffs (36 lines): diff -r 4c3da64e4d92 -r cadd7701fcfe nbxmpp/tls_nb.py --- a/nbxmpp/tls_nb.py Mon Jan 27 20:18:13 2014 +0100 +++ b/nbxmpp/tls_nb.py Wed Jan 29 16:47:10 2014 +0100 @@ -369,17 +369,21 @@ # py-OpenSSL < 0.9 or old OpenSSL flags |= 16384 - # OpenSSL 1.0.1d supports TLS 1.1 and TLS 1.2 and - # fixes renegotiation in TLS 1.1, 1.2 by using the correct TLS version. - if OpenSSL.SSL.OPENSSL_VERSION_NUMBER >= 0x1000104f: - if self.tls_version != '1.0': - flags |= OpenSSL.SSL.OP_NO_TLSv1 - if self.tls_version not in ('1.0', '1.1'): - try: - flags |= OpenSSL.SSL.OP_NO_TLSv1_1 - except AttributeError, e: - # older py-OpenSSL - flags |= 0x10000000 + try: + # OpenSSL 1.0.1d supports TLS 1.1 and TLS 1.2 and + # fixes renegotiation in TLS 1.1, 1.2 by using the correct TLS version. + if OpenSSL.SSL.OPENSSL_VERSION_NUMBER >= 0x1000104f: + if self.tls_version != '1.0': + flags |= OpenSSL.SSL.OP_NO_TLSv1 + if self.tls_version not in ('1.0', '1.1'): + try: + flags |= OpenSSL.SSL.OP_NO_TLSv1_1 + except AttributeError, e: + # older py-OpenSSL + flags |= 0x10000000 + except AttributeError, e: + pass # much older py-OpenSSL + tcpsock._sslContext.set_options(flags)
1
0
0
0
gajim: Backed out changeset c1f88dc9e4d0 of backed out changeset...
by Gajim
29 Jan '14
29 Jan '14
changeset 77d4c5bf1993 in /home/hg/repos/gajim author: Fedor Brunner <fedor.brunner(a)azet.sk> branches:
details:http://hg.gajim.org/gajim?cmd=changeset;node=77d4c5bf1993
description: Backed out changeset c1f88dc9e4d0 of backed out changeset 4ba5c2f6386e diffstat: src/common/config.py | 1 + src/common/connection.py | 4 +++- 2 files changed, 4 insertions(+), 1 deletions(-) diffs (27 lines): diff -r c1f88dc9e4d0 -r 77d4c5bf1993 src/common/config.py --- a/src/common/config.py Wed Jan 29 14:42:14 2014 +0100 +++ b/src/common/config.py Wed Jan 29 16:22:17 2014 +0100 @@ -349,6 +349,7 @@ 'enable_esessions': [opt_bool, True, _('Enable ESessions encryption for this account.')], 'autonegotiate_esessions': [opt_bool, True, _('Should Gajim automatically start an encrypted session when possible?')], 'connection_types': [ opt_str, 'tls ssl plain', _('Ordered list (space separated) of connection type to try. Can contain tls, ssl or plain')], + 'tls_version': [ opt_str, '1.0', '' ], 'cipher_list': [ opt_str, 'HIGH:!aNULL:RC4-SHA', '' ], 'action_when_plaintext_connection': [ opt_str, 'warn', _('Show a warning dialog before sending password on an plaintext connection. Can be \'warn\', \'connect\', \'disconnect\'') ], 'warn_when_insecure_ssl_connection': [ opt_bool, True, _('Show a warning dialog before using standard SSL library.') ], diff -r c1f88dc9e4d0 -r 77d4c5bf1993 src/common/connection.py --- a/src/common/connection.py Wed Jan 29 14:42:14 2014 +0100 +++ b/src/common/connection.py Wed Jan 29 16:22:17 2014 +0100 @@ -1239,9 +1239,11 @@ if not os.path.exists(cacerts): cacerts = '' mycerts = common.gajim.MY_CACERTS + tls_version = gajim.config.get_per('accounts', self.name, + 'tls_version') cipher_list = gajim.config.get_per('accounts', self.name, 'cipher_list') - secure_tuple = (self._current_type, cacerts, mycerts, cipher_list) + secure_tuple = (self._current_type, cacerts, mycerts, tls_version, cipher_list) con = nbxmpp.NonBlockingClient( domain=self._hostname,
1
0
0
0
gajim: Backed out changeset 4ba5c2f6386e
by Gajim
29 Jan '14
29 Jan '14
changeset c1f88dc9e4d0 in /home/hg/repos/gajim author: Fedor Brunner <fedor.brunner(a)azet.sk> branches:
details:http://hg.gajim.org/gajim?cmd=changeset;node=c1f88dc9e4d0
description: Backed out changeset 4ba5c2f6386e I have submitted the 'tls_version' to the incorrect default branch. The correct submit was done in changeset 15331:b5831b64e5d2 , branch gajim_0.16 . diffstat: src/common/config.py | 1 - src/common/connection.py | 4 +--- 2 files changed, 1 insertions(+), 4 deletions(-) diffs (27 lines): diff -r 4ba5c2f6386e -r c1f88dc9e4d0 src/common/config.py --- a/src/common/config.py Mon Jan 27 16:31:08 2014 +0100 +++ b/src/common/config.py Wed Jan 29 14:42:14 2014 +0100 @@ -349,7 +349,6 @@ 'enable_esessions': [opt_bool, True, _('Enable ESessions encryption for this account.')], 'autonegotiate_esessions': [opt_bool, True, _('Should Gajim automatically start an encrypted session when possible?')], 'connection_types': [ opt_str, 'tls ssl plain', _('Ordered list (space separated) of connection type to try. Can contain tls, ssl or plain')], - 'tls_version': [ opt_str, '1.0', '' ], 'cipher_list': [ opt_str, 'HIGH:!aNULL:RC4-SHA', '' ], 'action_when_plaintext_connection': [ opt_str, 'warn', _('Show a warning dialog before sending password on an plaintext connection. Can be \'warn\', \'connect\', \'disconnect\'') ], 'warn_when_insecure_ssl_connection': [ opt_bool, True, _('Show a warning dialog before using standard SSL library.') ], diff -r 4ba5c2f6386e -r c1f88dc9e4d0 src/common/connection.py --- a/src/common/connection.py Mon Jan 27 16:31:08 2014 +0100 +++ b/src/common/connection.py Wed Jan 29 14:42:14 2014 +0100 @@ -1239,11 +1239,9 @@ if not os.path.exists(cacerts): cacerts = '' mycerts = common.gajim.MY_CACERTS - tls_version = gajim.config.get_per('accounts', self.name, - 'tls_version') cipher_list = gajim.config.get_per('accounts', self.name, 'cipher_list') - secure_tuple = (self._current_type, cacerts, mycerts, tls_version, cipher_list) + secure_tuple = (self._current_type, cacerts, mycerts, cipher_list) con = nbxmpp.NonBlockingClient( domain=self._hostname,
1
0
0
0
gajim: Disable TLS tickets (RFC 5077) in OpenSSL Context for XTLS.
by Gajim
29 Jan '14
29 Jan '14
changeset 1e160dfa3c32 in /home/hg/repos/gajim author: Fedor Brunner <fedor.brunner(a)azet.sk> branches: gajim_0.16
details:http://hg.gajim.org/gajim?cmd=changeset;node=1e160dfa3c32
description: Disable TLS tickets (RFC 5077) in OpenSSL Context for XTLS. More on the effect of TLS tickets:
https://media.blackhat.com/us-13/US-13-Daigniere-TLS-Secrets-Slides.pdf
Fixes #7638 diffstat: src/common/jingle_xtls.py | 3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diffs (13 lines): diff -r 8d9c23ae110c -r 1e160dfa3c32 src/common/jingle_xtls.py --- a/src/common/jingle_xtls.py Mon Jan 27 20:18:42 2014 +0100 +++ b/src/common/jingle_xtls.py Wed Jan 29 14:12:10 2014 +0100 @@ -99,7 +99,8 @@ constructs and returns the context objects """ ctx = SSL.Context(SSL.SSLv23_METHOD) - flags = (SSL.OP_NO_SSLv2 | SSL.OP_NO_SSLv3 | SSL.OP_SINGLE_DH_USE) + flags = (SSL.OP_NO_SSLv2 | SSL.OP_NO_SSLv3 | SSL.OP_SINGLE_DH_USE \ + | SSL.OP_NO_TICKET) ctx.set_options(flags) ctx.set_cipher_list('HIGH:!aNULL:!3DES')
1
0
0
0
gajim: Add ability to configure TLS protocol version.
by Gajim
27 Jan '14
27 Jan '14
changeset 4ba5c2f6386e in /home/hg/repos/gajim author: Fedor Brunner <fedor.brunner(a)azet.sk> branches:
details:http://hg.gajim.org/gajim?cmd=changeset;node=4ba5c2f6386e
description: Add ability to configure TLS protocol version. add configuration option tls_version Related to
https://python-nbxmpp.gajim.org/ticket/17
diffstat: src/common/config.py | 1 + src/common/connection.py | 4 +++- 2 files changed, 4 insertions(+), 1 deletions(-) diffs (27 lines): diff -r d55c0a3e26b1 -r 4ba5c2f6386e src/common/config.py --- a/src/common/config.py Mon Dec 23 23:26:54 2013 +0100 +++ b/src/common/config.py Mon Jan 27 16:31:08 2014 +0100 @@ -349,6 +349,7 @@ 'enable_esessions': [opt_bool, True, _('Enable ESessions encryption for this account.')], 'autonegotiate_esessions': [opt_bool, True, _('Should Gajim automatically start an encrypted session when possible?')], 'connection_types': [ opt_str, 'tls ssl plain', _('Ordered list (space separated) of connection type to try. Can contain tls, ssl or plain')], + 'tls_version': [ opt_str, '1.0', '' ], 'cipher_list': [ opt_str, 'HIGH:!aNULL:RC4-SHA', '' ], 'action_when_plaintext_connection': [ opt_str, 'warn', _('Show a warning dialog before sending password on an plaintext connection. Can be \'warn\', \'connect\', \'disconnect\'') ], 'warn_when_insecure_ssl_connection': [ opt_bool, True, _('Show a warning dialog before using standard SSL library.') ], diff -r d55c0a3e26b1 -r 4ba5c2f6386e src/common/connection.py --- a/src/common/connection.py Mon Dec 23 23:26:54 2013 +0100 +++ b/src/common/connection.py Mon Jan 27 16:31:08 2014 +0100 @@ -1239,9 +1239,11 @@ if not os.path.exists(cacerts): cacerts = '' mycerts = common.gajim.MY_CACERTS + tls_version = gajim.config.get_per('accounts', self.name, + 'tls_version') cipher_list = gajim.config.get_per('accounts', self.name, 'cipher_list') - secure_tuple = (self._current_type, cacerts, mycerts, cipher_list) + secure_tuple = (self._current_type, cacerts, mycerts, tls_version, cipher_list) con = nbxmpp.NonBlockingClient( domain=self._hostname,
1
0
0
0
gajim: require nbxmpp 0.3.1
by Gajim
27 Jan '14
27 Jan '14
changeset 8d9c23ae110c in /home/hg/repos/gajim author: Yann Leboulanger <asterix(a)lagaule.org> branches: gajim_0.16
details:http://hg.gajim.org/gajim?cmd=changeset;node=8d9c23ae110c
description: require nbxmpp 0.3.1 diffstat: src/gajim.py | 6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diffs (18 lines): diff -r b5831b64e5d2 -r 8d9c23ae110c src/gajim.py --- a/src/gajim.py Mon Jan 27 16:31:08 2014 +0100 +++ b/src/gajim.py Mon Jan 27 20:18:42 2014 +0100 @@ -70,11 +70,11 @@ try: from distutils.version import LooseVersion as V - if V(nbxmpp.__version__) < V("0.3"): - print 'Gajim needs python-nbxmpp > 0.3 to run. Quiting...' + if V(nbxmpp.__version__) < V("0.3.1"): + print 'Gajim needs python-nbxmpp > 0.3.1 to run. Quiting...' sys.exit() except: - print 'Gajim needs python-nbxmpp > 0.3 to run. Quiting...' + print 'Gajim needs python-nbxmpp > 0.3.1 to run. Quiting...' sys.exit() from common import demandimport
1
0
0
0
← Newer
1
2
3
4
Older →
Jump to page:
1
2
3
4
Results per page:
10
25
50
100
200