[Gajim-devel] 2 problems with Gajim, GnuPG and Windows

Илья Валеев ilya-valeev at yandex.ru
Thu May 12 03:21:12 CEST 2016

11.05.2016 00:01, Yann Leboulanger пишет:
> On 05/10/2016 02:42 AM, Илья Валеев wrote:
>> Hello!
>> 1. Sender
>> Gajim 0.16.5, Debian 8 x64, GnuPG 2.0.26
>> 2. Recipient
>> Gajim 0.16.5-1, Windows 7 x64, Gpg4win 2.3.1 (GnuPG 2.0.30)
>> I created 2 RSA+RSA keys on sender computer, then copy 1 keypair and 1
>> open key to recipient computer. There are 2 problems:
>> *I. Not trusted key*
>> ...
>> *II. Cyrillic decryption on Windows*
>> ...
> For your first problem, we just raise wht gpg tells us. If Gajim says
> you don't trust the key, it's because gpg says so. Do you trust your own
> key? We encrypt to both our key and recipient key so carbon can work
> correctly.
Yes, you are right. When I set trustlevel to recipients own key on he's
computer to 5, problem gone.
> For your second problem, I recently worked with another user on
> improving that. And if you install this version [0], it should be fixed:
> [0]: https://gajim.org/downloads/snap/win/gajim_0.16.5_gpg7.exe

This version works perfect with GnuPG, this problem is also gone.

> On 05/10/2016 03:24 AM, Илья Валеев wrote:
>> And third problem: when OpenPGP toggled on in account settings on
>> recipient, Gajim reconnects with problems.
>> Sometimes it stay in "reconnect" state. Sometimes it looks like it in
>> "reconnect" state, but actually online (all contacts shows as offline,
>> mouse over account name in roster shows that account online). And very
>> rarely it reconnects normally.
>> Turn Gajim off and run it again helps.
> Hmm I never experienced this problem. Are there errors in gajim.log? (In
> c:\Users\LOGIN\AppData\Roaming\Gajim)
> Could you open XML console before you try this reconnect to see where it
> hangs?

Since I install "gpg7" version I does not faced with this. Hope this solved.

I'm very glad, /thank you/!

And if we are talking about it, I have two more issues:

*I**. Ctrl+C/Ctrl+V does not work*
Affects on 0.16.5 and 0.16.5_gpg7. There are no errors in gajim.log.

*II. Image plugin does not see that same plugin installed on contact's
Image plugin button is not active, "This contact does no support
XHTML_IM". Affects on both computers, sender's and recipient's. It
affects even if sender enables second resource (Conversations 1.12.2,
which support this XEP too as I know). I'm not sure is this bug: for
example, transport contacts from my local server have this button active.

Can these issues be solved?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gajim.org/pipermail/gajim-devel/attachments/20160512/944f3aaa/attachment.html>

More information about the Gajim-devel mailing list