[Gajim-devel] bug report: video call not working for me with rc2 (and versions before)

Florian fbugs at gmx.net
Tue Jul 15 23:33:23 CEST 2014

Another little bug report to the mailing list (I checked today and it
seems that the creation of new accounts on trac is still disabled):

I would like to use gajim for video/audio calls, but unfortunately it
does not work. I tried it a couple of times with 0.15.4 in the past, but
gajim reliably froze when receiving a call. I then decided to wait for
0.16, and now with gajim 0.16rc1/rc2 I have given it another try.

Unfortunately I still haven't been able to use it for audio/video call.
I tried to find a way to report a reproducible error behavior but it's
hard (and I do not want to spend more than a couple of hours on it). One
thing which happens often is similar to the behavior I saw on 0.15.4: On
receiving a call a window pops up asking if I want to answer the call.
After clicking on "Yes", the window freezes together with the rest of
gajim and I need to kill gajim. I ran gajim with "gajim -v" but there is
absolutely no debug output when clicking on "Yes" or afterwards, it
simply freezes.

Another thing I see is that clicking on the video or audio buttons on
the chat window, the window changes its size, probably to make space for
the incoming video frame, and a video frame showing the video from my
own webcam is shown. The rest of the chat window is not re-drawn
correctly (some elements are cut in halfs etc) and usually the chat
window cannot be closed anymore. gajim needs to be killed then.

FWIW, xmpp video calls work very nicely with empathy on the same computer.

Version details:

I installed rc2 on a current debian testing by adding "deb
ftp://ftp.gajim.org/debian unstable main" to my sources list. farstream
and various gstreamer plugins are installed.

Thanks for your attention and for your work on gajim and sorry for not
being able to provide a more straight-forward bug report.


More information about the Gajim-devel mailing list