[Gajim-devel] Gajim-svn and problem with SOCKS5 proxy

Marcin Zajączkowski mszpak at wp.pl
Fri Jun 13 23:07:41 CEST 2008

On 2008-06-10 16:01, Yann Leboulanger wrote:
> Marcin Zajączkowski a écrit :
>> I'm unable to use SOCKS5 proxy (tested with privoxy & tor and 
>> Gajim-svn - 20080604 night build). Every time I try to connect I see 
>> on my console (gajim.py -v):
>> DEBUG: CONNECTproxy start Plugging 
>> <common.xmpp.transports_nb.NBSOCKS5PROXYsocket instance at 0x98015cc> 
>> into <common.xmpp.client_nb.NonBlockingClient instance at 0x904e08c>
>> DEBUG: CONNECTproxy start Proxy server contacted, performing 
>> authentification
>> DEBUG: CONNECTproxy sent
>> and nothing more happens. I tried with using HTTP_PROXY environment 
>> variable and manual proxy definition as well. I haven't find any 
>> similar tickets in trac.
>> Maybe you know what can be wrong?
>> Is it possible to increase a logging level to see more details about 
>> that?

> I haven't tested with tor + privoxy, but with ssh -D, and it works nicely:

Thank you for your answer Yann.
I checked my Gajim with ssh -D (I didn't even know about that option to 
get SOCKS5 proxy) and it was fine. I have also checked it with pure Tor 
and it worked either. It seems to be an issue with privoxy itself.
I'm a little bit astonish, because a few other apps work with privoxy 
without any problem. I will try to debug it on the privoxy side.


More information about the Gajim-devel mailing list