[Gajim-devel] gajim 0.11 causes JID too long error in Wildfire server

Günter Dannoritzer dannoritzer at web.de
Wed Apr 4 14:34:37 CEST 2007

yann wrote:
> indeed in the middle of your log, gajim gets a </stream:stream> without 
> any reason. This sounds like a server pb, as it work on other wildfire 
> servers. Have you tried with other clients ? do you see something 
> different in logs ?

I had the same problem with gajim on the 3.0.1 wildfire server. Also
used earlier versions of gajim and had that problem.

I just tried using spark, the client that comes from the same company
that develops wildfire, and that works fine.

Now there happened something interesting when I was doing that test.

I logged in with spark and checked the log on the wildfire server and
there was no error message from that log in.

Then I forgot to log out with spark and logged in with gajim as well and
the login happened right away. Checking the log of the wildfire server
there was no error from that login.

In the gajim rooster it shows spark with priority 0 and gajim with
priority 50. Actually, that is the first time that I have an entry for
my own login in my rooster. Before I only had entries for the other
users in my rooster.

It is getting better from here.

I logged out spark and logged out gajim as well.

After login in with gajim again it logged in right away without any
error message in the wildfire error log. I still have the entry for
myself with the spark resource in the rooster. Showing my status as offline.

I haven't figured out yet how to delete that entry in the rooster. I
will try to get rid of it and login again. Wonder whether I am getting
that error then again. With that entry, there is not right-mouse menu
"Remove from Roster" in gajim as there is for any of the other entries
that I have in the rooster.



More information about the Gajim-devel mailing list